miércoles, 25 de julio de 2012

Comandos básicos para trabajar con Packet Tracer



COMANDOS
 BÁSICOS ROUTER CISCO

1. Modo de Usuario:
El símbolo > que aparece después del nombre del router indica que se pueden ejecutar comandos en el Modo de usuario. La línea de comandos de CISCO IOS tiene varios modos de ejecución en los que sólo se pueden utilizar sólo determinados comandos. En total, hay cientos de comandos y muchos de ellos tienen numerosas opciones. Sin embargo, para los propósitos del Laboratorio sólo es necesario conocer algunos de ellos. Hay dos modos de ejecución básicos denominados Modo de usuario y Modo de administrador. Además, desde este último modo se puede acceder a otros tres modos denominados Modo de configuración global, Modo de configuración de interfaz y Modo de configuración de router. Cada uno de los modos se puede identificar porque el prompt de cada uno de ellos es distinto (Figura 1). En cada uno de los modos puede obtenerse una lista de los comandos disponibles tecleando el signo de interrogación (?). Por ejemplo, para el Modo de usuario: R1>?

FIGURA 1: Prompt de los diferentes modos de ejecución de CISCO IOS suponiendo que el nombre del router es R1

La Figura 2 resume las transiciones entre los cinco modos de ejecución de CISCO IOS. A continuación se detallan las funciones cada uno de estos modos y algunos de los comandos disponibles, en particular, los que se utilizan para realizar la transición de un modo a otro.

FIGURA 2: Modos de ejecución de comandos en CISCO IOS8
8: Adaptado del libro “Mastering Networks: An Internet Lab Manual”. J. Liebeherr, M. El Zarki. Addison-Wesley. 2004

Algunos de los comandos disponibles en el Modo de usuario son los siguientes:

enable

Acceso al Modo de administrador.

exit

Finaliza la conexión con el router.

ping

Envía mensajes de petición de eco.

show

Muestra información del sistema.

show version
Información no privilegiada de hardware y software

traceroute

Traza una ruta hasta un destino (número de saltos).
Ejemplo:
       traceroute 192.168.1.4

Para obtener la lista completa de comandos, hay que escribir el signo de interrogación ? en la línea de comandos. Ejemplo:

Router>?
Exec commands:
<1-99> Session number to resume
access-enable Create a temporary Access-List entry
access-profile Apply user-profile to interface
clear Reset functions
connect Open a terminal connection

Para obtener información adicional sobre las opciones de un comando en cualquiera de los modos se teclea el nombre del comando seguido del signo ?. Ejemplo:

Router>show ?
backup Backup status
clock Display the system clock

2. Modo de administrador
El Modo de administrador permite ver o cambiar la configuración del router. Para acceder a este modo desde el Modo de usuario hay que ejecutar el comando enable:

Router>enable
Router#

Algunos de los comandos disponibles en el Modo de administrador son los siguientes:

configure

Opciones de configuración.

configure terminal
Accede al Modo de configuración global

clear ip route *

Borra la tabla de rutas.

disable

Retorna al Modo de usuario.

exit

Finaliza la conexión con el router.

ping

Envía mensajes de petición de eco.

reload

Reinicia el sistema.

show

Muestra información privilegiada del sistema.

show interfaces
Información de las interfaces

show interfaces description
Muestra las interfaces del equipo, estado de Capa Física y Capa de Enlace y descripción.
show ip arp
Muestra la tabla ARP

show ip route
Muestra la tabla de rutas

show protocols
Información IP y enrutamiento

show running-config
Muestra la configuración completa del equipo

show startup-config
Configuración de arranque del sistema

Los archivos running-config y startup-config contienen información sobre las configuraciones actual e inicial del sistema, respectivamente. El archivo startup-config contiene la secuencia de comandos de CISCO IOS que se ejecutan al arrancar o reiniciar el sistema.

Cuando el router arranca, la información del archivo startup-config se copia en el archivo running-config, en el cuál se irán reflejando los cambios que se vayan realizando en la configuración. Si se desea que estos cambios no desaparezcan al reiniciar el sistema operativo, habría que guardar el contenido actual del archivo running-config en el archivo startup-config.

3. Modo de configuración global
El Modo de configuración global permite cambiar parámetros de configuración del router y sirve de puerta de acceso a los modos de configuración de las interfaces y de los protocolos de enrutamiento que se describen en los dos apartados siguientes. Para acceder a este modo desde el Modo de administrador hay que ejecutar el siguiente comando:

Router#configure terminal
Router(config)#


La opción terminal del comando configure indica al router que la configuración se va a realizar desde la consola. Existen otras alternativas para configurar el router, por ejemplo, cargando un archivo de configuración o transfiriéndolo desde un equipo remoto.

Algunos de los comandos disponibles en este modo son los siguientes:

end

Regresa al Modo de administrador.

exit

Regresa al Modo de administrador.

interface

Accede al Modo de configuración de la interfaz seleccionada.
Ejemplo:
    interface Ethernet 0
    interface Serial 0
ip

Configuración IP.

ip route
Establece una ruta estática

ip routing
Habilita el enrutamiento IP

no

Niega un comando (ejecuta lo contrario al comando).

no ip routing
Deshabilita el enrutamiento IP

router

Selecciona un protocolo de enrutamiento para configurarlo.

router rip
Selecciona el protocolo RIP

Por ejemplo, para habilitar el enrutamiento IP en el router R3 y añadir a la tabla de rutas la red de destino 192.168.5.0 /24 con dirección de próximo salto 192.168.4.2 (que es la dirección IP de la interfaz serie del router R4) se ejecutarían las siguientes secuencias de comandos partiendo del Modo de usuario:

R3>enable
R3#configure terminal
R3(config)#ip routing
R3(config)#ip route 192.168.5.0 255.255.255.0 192.168.4.2

Si ahora se vuelve al Modo de administrador y se observa el contenido de la tabla de rutas aparecerá una entrada con la ruta estática que se acaba de añadir marcada con el código S (Static):

R3(config)#exit
R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o – ODR
S 192.168.5.0/24 [120/1] via 192.168.4.2, 00:00:10, Ethernet0
C 192.168.3.0/24 is directly connected, Ethernet0
C 192.168.4.0/24 is directly connected, Serial0

Además de la ruta estática aparecen otras dos rutas con el código C (Connected) que son las dos redes a las que el router R3 está conectado a través de sus interfaces Ethernet0 y Serial0, las cuáles se añaden a la tabla de forma automática.

4. Modo de configuración de interfaz
El Modo de configuración de interfaz se utiliza para configurar una interfaz del router, por ejemplo, para asignarle una dirección IP. Para acceder a este modo desde el Modo de configuración global hay que ejecutar el  comando interface seguido del nombre de la interfaz que se desea configurar, por ejemplo:

R1(config)#interface Serial 0
R1(config-if)#

Algunos de los comandos disponibles para configurar las interfaces de red son los siguientes:

clock

Configura el reloj de la interfaz serie, en bits por segundo.
Ejemplo:
    clock rate 4800
encapsulation

Tipo de encapsulado para la interfaz serie.
encapsulation hdlc
Encapsulado hdlc (High Level Data Link)

ip

Comandos de configuración de IP.

ip address   dirección_IP   máscara
Asignación de dirección IP

shutdown

Deshabilita la interfaz seleccionada.

no shutdown
Habilita la interfaz seleccionada


Por ejemplo para asignar la dirección IP 192.168.2.1/24 a la interfaz serie del router R1 se ejecutaría la siguiente secuencia de comandos partiendo del Modo de usuario y regresando, después de configurar la interfaz, al Modo de administrador:

R1>enable
R1#configure terminal
R1(config)#interface serial 0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#encapsulation hdlc
R1(config-if)#clock rate 4800
R1(config-if)#no shutdown
R1(config-if)#end
R1#


5. Modo de configuración de router
El Modo de configuración de router se utiliza para establecer o modificar los parámetros de un determinado protocolo de enrutamiento. Para poder acceder a este modo, primero hay que habilitar el enrutamiento IP en el router desde el Modo de configuración global:

R1(config)#ip routing

Y seleccionar luego el protocolo deseado. Por ejemplo, si se selecciona el protocolo RIP (Router Information Protocol):

R1(config)#router rip
R1(config-router)#

Algunos de los comandos que se pueden ejecutar en este modo con el protocolo RIP son los siguientes:

exit

Sale del modo de configuración del router.

network

Habilita el protocolo RIP en una red IP.
Ejemplo:
    network 192.168.4.0
no network

Deshabilita la red
Ejemplo:
    no network 192.168.4.0
version

Cambia la versión del protocolo RIP.
Ejemplo:
    version 2 Cambia a RIPv2


Otros comandos de interés:
A continuación se detallan algunos comandos que pueden ser de utilidad para completar el Packet Tracer.

show interfaces status (para switches)
Muestra las interfaces del equipo, descripción, estado, VLAN, dúplex, velocidad, tipo.

show mac-address (para switches)
Muestra la dirección MAC de la VLAN por defecto.
show ip interface brief (para routers y PC’s)
Muestra las interfaces del equipo, su dirección IP, estado de Capa Física y Capa de Enlace.

RESUMEN COMANDOS BÁSICO CISCO

 


No hay comentarios:

Publicar un comentario en la entrada

Objetivo General de la Asignatura

"Estudiar y analizar los diferentes conceptos y tecnologías relacionadas con las redes de datos y sus aplicaciones
, así como la comprensión de conocimientos para el uso y administración de redes de computadoras en múltiples sistemas operativos".